ChargeHQ not utilising all available excess production

Hi team,
I’ve got a setup with a Tesla charger and SolarEdge in my home.

Everything has been working well up until recently. However, it seems that ChargeHQ isn’t utilising the maximum from my excess production.

I had it charging today and noticed that it didn’t utilize all the excess to charge my EV. the attached graph shows how it limited the Tesla charging way below what the solar system had to offer in excess (I had additional 5kw available at 12pm and yet, chargeHQ didn’t increase the supply of my EV charger.

I have NOT limited the “Charge Amps” and left the setting on AUTO (second screenshot

Also refer to the Solar Tracking settings and Advanced Settings screens also attached.

One important information is that I’ve got two SolarEdge inverters… One was recently replaced. However from an API perspective, they should read as a single entity.

As part of my troubleshooting steps, I’ve disconnected and reconnected the SolarEdge API on the ChargeHQ app. this didn’t reslve the issue.

Would you please advise on where to check further for potential problems?

Rony Zlochevsky


It looks like the energy meter on your Solar Edge inverter is not monitoring the energy consumption of your EV charger. The attached graph from our logs shows the same period as your Solar Edge graph. Export matches production (green) minus consumption (yellow) without taking into account the EV charging load.

Charge HQ can work around this, go to Settings → Solar Tracking → Advanced and toggle on Consumption Excludes Charging.

Once enabled, Charge HQ will add the EV charging load to home consumption when calculating excess.

When the setting is required, but not enabled, Charge HQ gets confused and stops updating frequently.

The metering setup may have changed when your inverter was changed. Looking at data from 6 months ago, the EV charging load was included in the home energy consumption reported by Solar Edge.